So-net無料ブログ作成

Mac OS X 10.9 でbinutilをビルドする

Mac book Air (Mac OS X 1.9 Mavericks)で、H8, ARMのクロスコンパイル環境を
作ろうとしてが、binutilのビルドでどうしてもこける。

  'sbrk' is deprecated 

とおこられてしまう。Max OS X Leopard (10.6)だと大丈夫だった。

ググってみると、以下のサイトで同じ現象に関して回答があった。

■参照

以下のconfigure指定でで一応binutilがうまくビルドできた。

$ cd binutils-2.24

$ mkdir build

$ cd build

$ CC=gcc-4.9 CFLAGS=-Wno-error=deprecated-declarations ../configure --target=h8300-elf --disable-nls --prefix=/usr/local/h8-elf

$ make




以上。


nice!(0)  コメント(0)  トラックバック(0) 

nice! 0

コメント 0

コメントを書く

お名前:
URL:
コメント:
画像認証:
下の画像に表示されている文字を入力してください。

トラックバック 0

この広告は前回の更新から一定期間経過したブログに表示されています。更新すると自動で解除されます。

×

この広告は1年以上新しい記事の更新がないブログに表示されております。